Справочное руководство по MySQL версии 4.1.1-alpha




2.3.4 Установка из экспериментального набора исходных кодов


Предупреждение: этот раздел необходимо читать только в том случае, если вы хотите помочь нам в тестировании нового кода. Пользователи, которые просто хотят установить MySQL и запустить его на своей системе, должны использовать стандартную версию дистрибутива (либо исходный код, либо бинарный дистрибутив).

Чтобы получить самый последний из разработанных наборов исходных кодов, используйте следующие инструкции:

  1. Загрузите программу BitKeeper с http://www.bitmover.com/cgi-bin/download.cgi. Для доступа к нашему хранилищу вам понадобится версия Bitkeeper 3.0 или более новая.

  2. Выполните инструкции по установке этой программы.

  3. После установки BitKeeper сначала перейдите в каталог, из которого собираетесь работать, затем используйте одну из приведенных ниже команд, для получения желаемой копии ветви MySQL.

    Чтобы клонировать ветку 3.23:

    shell> bk clone bk://mysql.bkbits.net/mysql-3.23 mysql-3.23

    Чтобы клонировать ветку 4.0:

    shell> bk clone bk://mysql.bkbits.net/mysql-4.0 mysql-4.0

    Чтобы клонировать ветку 4.1:

    shell> bk clone bk://mysql.bkbits.net/mysql-4.1 mysql-4.1

    В предыдущих примерах набор исходных кодов будет установлен в подкаталогах `mysql-3-23/', `mysql-4.0/' или `mysql-4.1/' вашего текущего каталога.

    Если вы находитесь за брендмауером, и можете только делать HTTP-запросы, вы можете также использовать BitKeeper по HTTP.

    Если вы используете прокси-сервер, просто установите переменную окружения http_proxy:

    shell> export http_proxy="http://your.proxy.server:8080/"

    И теперь просто замените bk:// на http:// когда будете делать клонирование. Например:

    shell> bk clone http://mysql.bkbits.net/mysql-4.1 mysql-4.1

    Первоначальная загрузка набора исходных кодов может потребовать времени в зависимости от скорости вашего соединения; будьте терпеливы.

  4. Чтобы запустить следующий набор команд, вам понадобятся программы GNU make, autoconf 2.53 (или новее), automake 1.5, libtool 1.4 и m4. Программа automake 1.7 (или новее) еще не работает.




    Содержание  Назад  Вперед